perl-Dist-CheckConflicts-0.110.0-9-omv4001.noarch.rpm


Advertisement

Description

perl-Dist-CheckConflicts - Declare version conflicts for your dist

Property Value
Distribution OpenMandriva Cooker
Repository OpenMandriva Main Release i586
Package filename perl-Dist-CheckConflicts-0.110.0-9-omv4001.noarch.rpm
Package name perl-Dist-CheckConflicts
Package version 0.110.0
Package release 9-omv4001
Package architecture noarch
Package type rpm
Category Development/Perl
Homepage http://metacpan.org/pod/Dist::CheckConflicts
License GPLv2+ or Artistic
Maintainer -
Download size 24.80 KB
Installed size 55.37 KB
One shortcoming of the CPAN clients that currently exist is that they have
no way of specifying conflicting downstream dependencies of modules. This
module attempts to work around this issue by allowing you to specify
conflicting versions of modules separately, and deal with them after the
module is done installing.
For instance, say you have a module 'Foo', and some other module 'Bar' uses
'Foo'. If 'Foo' were to change its API in a non-backwards-compatible way,
this would cause 'Bar' to break until it is updated to use the new API.
'Foo' can't just depend on the fixed version of 'Bar', because this will
cause a circular dependency (because 'Bar' is already depending on 'Foo'),
and this doesn't express intent properly anyway - 'Foo' doesn't use 'Bar'
at all. The ideal solution would be for there to be a way to specify
conflicting versions of modules in a way that would let CPAN clients update
conflicting modules automatically after an existing module is upgraded, but
until that happens, this module will allow users to do this manually.
This module accepts a hash of options passed to its 'use' statement, with
these keys being valid:

Alternatives

Package Version Architecture Repository
perl-Dist-CheckConflicts-0.110.0-9-omv4000.noarch.rpm 0.110.0 noarch OpenMandriva Main Release
perl-Dist-CheckConflicts - - -

Requires

Name Value
perl >= 5.006
perl(Carp) -
perl(Exporter) -
perl(Module::Runtime) >= 0.9.0
perl(base) -
perl(strict) -
perl(warnings) -

Provides

Name Value
perl(Dist::CheckConflicts) = 0.110.0
perl-Dist-CheckConflicts = 0.110.0-9

Download

Type URL
Mirror abf-downloads.openmandriva.org
Binary Package perl-Dist-CheckConflicts-0.110.0-9-omv4001.noarch.rpm
Source Package perl-Dist-CheckConflicts-0.110.0-9.src.rpm

Install Howto

  1. Enable the repository in Software Repository Picker:
    # om-repo-picker
  2. Install perl-Dist-CheckConflicts rpm package:
    # dnf install perl-Dist-CheckConflicts

Files

Path
/usr/share/doc/perl-Dist-CheckConflicts/Changes
/usr/share/doc/perl-Dist-CheckConflicts/LICENSE
/usr/share/doc/perl-Dist-CheckConflicts/META.json
/usr/share/doc/perl-Dist-CheckConflicts/META.yml
/usr/share/doc/perl-Dist-CheckConflicts/README
/usr/share/man/man3/Dist::CheckConflicts.3pm.xz
/usr/share/perl5/vendor_perl/Dist/CheckConflicts.pm

See Also

Package Description
perl-DynaLoader-Functions-0.003-3-omv4000.i686.rpm Perl module for deconstructed dynamic C library loading
perl-Email-Abstract-3.8.0-3-omv4001.noarch.rpm Unified interface to mail representations
perl-Email-Address-1.905.0-5-omv4001.noarch.rpm RFC 2822 Address Parsing and Creation
perl-Email-Date-1.104.0-8-omv4001.noarch.rpm Find and Format Date Headers
perl-Email-Date-Format-1.5.0-6-omv4001.noarch.rpm Produce RFC 2822 date strings
perl-Email-Simple-2.216.0-2-omv4001.noarch.rpm Simple parsing of RFC2822 message format and headers
perl-Encode-3.01-14-omv4001.i686.rpm Character encodings in Perl
perl-Encode-Detect-1.10.0-23-omv4001.i686.rpm An Encode::Encoding subclass that detects the encoding of data
perl-Encode-Locale-1.50.0-2-omv4001.noarch.rpm Determine the locale encoding
perl-Encode-devel-3.01-14-omv4001.noarch.rpm Character encodings in Perl
perl-Env-1.04-14-omv4001.noarch.rpm Perl module that imports environment variables as scalars or arrays
perl-Env-Path-0.190.0-5-omv4001.noarch.rpm Advanced operations on path variables
perl-Errno-1.30-14-omv4001.i686.rpm System errno constants
perl-Error-0.170.260-7-omv4001.noarch.rpm Error/exception handling in an OO-ish way
perl-Eval-Closure-0.140.0-3-omv4001.noarch.rpm Safely and cleanly create closures via string eval
Advertisement
Advertisement