rubygem-gem2rpm5-0.6.7-1-omv2013.0.noarch.rpm


Advertisement

Description

rubygem-gem2rpm5 - Generate rpm specfiles from gems

Property Value
Distribution OpenMandriva Cooker
Repository OpenMandriva Contrib Release x86_64
Package name rubygem-gem2rpm5
Package version 0.6.7
Package release 1-omv2013.0
Package architecture noarch
Package type rpm
Installed size 160.46 KB
Download size 59.78 KB
Official Mirror abf-downloads.openmandriva.org
Generate source rpms and rpm spec files from a Ruby Gem. The spec file is
adapted to first of all follow Mandriva Linux packaging guidelines, using
rpm5's gem_helper, while following the gem as much as necessary to remain
compatible without the bloat.

Alternatives

Package Version Architecture Repository
rubygem-gem2rpm5-0.6.7-1-omv2013.0.noarch.rpm 0.6.7 noarch OpenMandriva Contrib Release
rubygem-gem2rpm5 - - -

Requires

Name Value
ruby(abi) = 1.9.1
rubygems -

Provides

Name Value
rubygem(gem2rpm5) = 0.6.7
rubygem-gem2rpm5 = 0.6.7-1

Download

Type URL
Binary Package rubygem-gem2rpm5-0.6.7-1-omv2013.0.noarch.rpm
Source Package rubygem-gem2rpm5-0.6.7-1.src.rpm

Install Howto

  1. Enable OpenMandriva Contrib Release repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install rubygem-gem2rpm5 rpm package:
    # urpmi rubygem-gem2rpm5

Files

Path
/usr/bin/gem2rpm5
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/rdoc/Gem.html
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/rdoc/Gem2Rpm5.html
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/rdoc/LICENSE.html
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/rdoc/Object.html
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/rdoc/README.html
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/rdoc/String.html
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/rdoc/created.rid
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/rdoc/index.html
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/rdoc/rdoc.css
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/rdoc/Gem/Requirement.html
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/rdoc/images/brick.png
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/rdoc/images/brick_link.png
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/rdoc/images/bug.png
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/rdoc/images/bullet_black.png
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/rdoc/images/bullet_toggle_minus.png
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/rdoc/images/bullet_toggle_plus.png
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/rdoc/images/date.png
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/rdoc/images/find.png
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/rdoc/images/loadingAnimation.gif
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/rdoc/images/macFFBgHack.png
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/rdoc/images/package.png
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/rdoc/images/page_green.png
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/rdoc/images/page_white_text.png
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/rdoc/images/page_white_width.png
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/rdoc/images/plugin.png
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/rdoc/images/ruby.png
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/rdoc/images/tag_green.png
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/rdoc/images/wrench.png
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/rdoc/images/wrench_orange.png
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/rdoc/images/zoom.png
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/rdoc/js/darkfish.js
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/rdoc/js/jquery.js
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/rdoc/js/quicksearch.js
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/rdoc/js/thickbox-compressed.js
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/rdoc/lib/gem2rpm5_rb.html
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/ri/cache.ri
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/ri/created.rid
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/ri/Gem/cdesc-Gem.ri
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/ri/Gem/Requirement/cdesc-Requirement.ri
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/ri/Gem/Requirement/rpm_version_transform-i.ri
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/ri/Gem/Requirement/to_rpm-i.ri
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/ri/Gem2Rpm5/cdesc-Gem2Rpm5.ri
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/ri/Gem2Rpm5/convert-c.ri
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/ri/Gem2Rpm5/find_download_url-c.ri
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/ri/Gem2Rpm5/packager-c.ri
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/ri/Object/cdesc-Object.ri
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/ri/String/cdesc-String.ri
/usr/lib/ruby/gems/1.9.1/doc/gem2rpm5-0.6.7/ri/String/word_wrap-i.ri
/usr/lib/ruby/gems/1.9.1/gems/gem2rpm5-0.6.7/AUTHORS
/usr/lib/ruby/gems/1.9.1/gems/gem2rpm5-0.6.7/LICENSE
/usr/lib/ruby/gems/1.9.1/gems/gem2rpm5-0.6.7/README
/usr/lib/ruby/gems/1.9.1/gems/gem2rpm5-0.6.7/bin/gem2rpm5
/usr/lib/ruby/gems/1.9.1/gems/gem2rpm5-0.6.7/lib/gem2rpm5.rb
/usr/lib/ruby/gems/1.9.1/specifications/gem2rpm5-0.6.7.gemspec

Changelog

2012-02-15 - Per Øyvind Karlsen <peroyvind@mandriva.org> 0.6.7-1
+ Revision: 774256
- don't add buildrequires on rake for building ruby extensions anymore as it's
now provided by the ruby standard library
2012-02-12 - Per Øyvind Karlsen <peroyvind@mandriva.org> 0.6.6-1
+ Revision: 773462
- new version updated to work with ruby 1.9
2011-10-05 - Per Øyvind Karlsen <peroyvind@mandriva.org> 0.6.5-1
+ Revision: 703092
- new version
- remove legacy rpm stuff
- remove duplicated file from %%files
2011-03-10 - Per Øyvind Karlsen <peroyvind@mandriva.org> 0.6.4-2
+ Revision: 643308
- fix group of -doc packages produced..
2011-03-10 - Per Øyvind Karlsen <peroyvind@mandriva.org> 0.6.4-1
+ Revision: 643305
- new release
2011-03-10 - Per Øyvind Karlsen <peroyvind@mandriva.org> 0.6.3-1
+ Revision: 643256
- ship docs with main package
- new release: 0.6.3
- fix URL
- new release 0.6.2:
o remove newline on top of spec
o use %%setup in stead of %%gem_unpack
o use doc/%%{name}-%%{version} rather than hardcoding it in %%files
- imported package rubygem-gem2rpm5
2010-10-17 - Per Øyvind Karlsen <peroyvind@lappis> 0.6.1-1
- Initial package

See Also

Package Description
rubygem-gem_plugin-0.2.3-1-omv2013.0.noarch.rpm A plugin system based on rubygems that uses dependencies only
rubygem-gemcutter-0.7.1-2-omv2013.0.noarch.rpm Commands to interact with RubyGems.org
rubygem-gemcutter-doc-0.7.1-2-omv2013.0.noarch.rpm Documentation for rubygem-gemcutter
rubygem-haml-3.0.24-2-omv2015.0.noarch.rpm An elegant, structured XHTML/XML templating engine
rubygem-hashie-0.4.0-2-omv2015.0.noarch.rpm Your friendly neighborhood hash toolkit
rubygem-heckle-1.4.3-2-omv2015.0.noarch.rpm Heckle is unit test sadism(tm) at it's core
rubygem-highline-1.5.2-4-omv2015.0.noarch.rpm A high-level command-line IO library for ruby
rubygem-hoe-2.13.1-1-omv2013.0.noarch.rpm Hoe is a rake/rubygems helper for project Rakefiles
rubygem-hoe-doc-2.13.1-1-omv2013.0.noarch.rpm Documentation for rubygem-hoe
rubygem-hpricot-0.8.3-1-omv2013.0.x86_64.rpm A swift, liberal HTML parser with a fantastic library
rubygem-htmlentities-4.2.2-3-omv2015.0.noarch.rpm A module for encoding and decoding (X)HTML entities
rubygem-httpclient-2.1.5.2-2-omv2015.0.noarch.rpm Gives something like the functionality of libwww-perl (LWP) in Ruby
rubygem-i18n-0.6.9-5-omv2015.0.noarch.rpm New wave Internationalization support for Ruby
rubygem-i18n-doc-0.6.9-5-omv2015.0.noarch.rpm Documentation for rubygem-i18n
rubygem-icalendar-1.1.5-2-omv2015.0.noarch.rpm This is a Ruby library for dealing with iCalendar files
Advertisement
Advertisement