perl-Perl-Critic-More-1.3.0-3-omv2015.0.noarch.rpm


Advertisement

Description

perl-Perl-Critic-More - Stop mixing long strings with code

Property Value
Distribution OpenMandriva Cooker
Repository OpenMandriva Contrib x86_64
Package name perl-Perl-Critic-More
Package version 1.3.0
Package release 3-omv2015.0
Package architecture noarch
Package type rpm
Installed size 86.46 KB
Download size 37.34 KB
Official Mirror abf-downloads.openmandriva.org
This is a collection of the Perl::Critic manpage policies that are not
included in the Perl::Critic core for a variety of reasons:
* * Experimental
Some policies need some time to work out their kinks, test usability, or
gauge community interest. A subset of these will end up in the core
Perl::Critic someday.

Alternatives

Package Version Architecture Repository
perl-Perl-Critic-More-1.3.0-3-omv2015.0.noarch.rpm 1.3.0 noarch OpenMandriva Contrib
perl-Perl-Critic-More - - -

Requires

Name Value
perl(Carp) -
perl(English) -
perl(List::MoreUtils) -
perl(Perl::Critic::Policy) -
perl(Perl::Critic::Utils) -
perl(Readonly) -
perl(abi) >= 5.20.1

Provides

Name Value
perl(Perl::Critic::More) == 1.3.0
perl(Perl::Critic::Policy::CodeLayout::RequireASCII) == 1.3.0
perl(Perl::Critic::Policy::Editor::RequireEmacsFileVariables) == 1.3.0
perl(Perl::Critic::Policy::ErrorHandling::RequireUseOfExceptions) == 1.3.0
perl(Perl::Critic::Policy::Modules::PerlMinimumVersion) == 1.3.0
perl(Perl::Critic::Policy::Modules::RequirePerlVersion) == 1.3.0
perl(Perl::Critic::Policy::ValuesAndExpressions::RequireConstantOnLeftSideOfEquality) == 1.3.0
perl(Perl::Critic::Policy::ValuesAndExpressions::RestrictLongStrings) == 1.3.0
perl-Perl-Critic-More == 1.3.0-3:2015.0

Download

Type URL
Binary Package perl-Perl-Critic-More-1.3.0-3-omv2015.0.noarch.rpm
Source Package perl-Perl-Critic-More-1.3.0-3.src.rpm

Install Howto

  1. Enable OpenMandriva Contrib repository on Install and Remove Software"
  2. Update packages list:
    # urpmi.update -a
  3. Install perl-Perl-Critic-More rpm package:
    # urpmi perl-Perl-Critic-More

Files

Path
/usr/lib/perl5/vendor_perl/5.20.1/Perl/
/usr/lib/perl5/vendor_perl/5.20.1/Perl/Critic/More.pm
/usr/lib/perl5/vendor_perl/5.20.1/Perl/Critic/TODO.pod
/usr/lib/perl5/vendor_perl/5.20.1/Perl/Critic/Policy/
/usr/lib/perl5/vendor_perl/5.20.1/Perl/Critic/Policy/CodeLayout/RequireASCII.pm
/usr/lib/perl5/vendor_perl/5.20.1/Perl/Critic/Policy/Editor/RequireEmacsFileVariables.pm
/usr/lib/perl5/vendor_perl/5.20.1/Perl/Critic/Policy/ErrorHandling/RequireUseOfExceptions.pm
/usr/lib/perl5/vendor_perl/5.20.1/Perl/Critic/Policy/Modules/PerlMinimumVersion.pm
/usr/lib/perl5/vendor_perl/5.20.1/Perl/Critic/Policy/Modules/RequirePerlVersion.pm
/usr/lib/perl5/vendor_perl/5.20.1/Perl/Critic/Policy/ValuesAndExpressions/RequireConstantOnLeftSideOfEquality.pm
/usr/lib/perl5/vendor_perl/5.20.1/Perl/Critic/Policy/ValuesAndExpressions/RestrictLongStrings.pm
/usr/share/doc/perl-Perl-Critic-More/Changes
/usr/share/doc/perl-Perl-Critic-More/LICENSE
/usr/share/doc/perl-Perl-Critic-More/META.yml
/usr/share/doc/perl-Perl-Critic-More/README
/usr/share/man/man3/Perl::Critic::More.3pm.xz
/usr/share/man/man3/Perl::Critic::Policy::CodeLayout::RequireASCII.3pm.xz
/usr/share/man/man3/Perl::Critic::Policy::Editor::RequireEmacsFileVariables.3pm.xz
/usr/share/man/man3/Perl::Critic::Policy::ErrorHandling::RequireUseOfExceptions.3pm.xz
/usr/share/man/man3/Perl::Critic::Policy::Modules::PerlMinimumVersion.3pm.xz
/usr/share/man/man3/Perl::Critic::Policy::Modules::RequirePerlVersion.3pm.xz
/usr/share/man/man3/Perl::Critic::Policy::ValuesAndExpressions::RequireConstantOnLeftSideOfEquality.3pm.xz
/usr/share/man/man3/Perl::Critic::Policy::ValuesAndExpressions::RestrictLongStrings.3pm.xz
/usr/share/man/man3/Perl::Critic::TODO.3pm.xz

See Also

Package Description
perl-Perl-Critic-Nits-1.0.0-5-omv2015.0.noarch.rpm Policies of nits I like to pick
perl-Perl-Critic-PetPeeves-JTRAMMELL-0.40.0-3-omv2015.0.noarch.rpm Prohibit superfluous initializations
perl-Perl-Critic-Pulp-85.0.0-1-omv2014.1.noarch.rpm Don't use Foo:: style barewords
perl-Perl-Critic-Storable-0.10.0-5-omv2015.0.noarch.rpm Perl::Critic policy for using Storable
perl-Perl-Critic-StricterSubs-0.30.0-5-omv2015.0.noarch.rpm Perl::Critic plugin for stricter subroutine checks
perl-Perl-Critic-Swift-1.0.3-4-omv2015.0.noarch.rpm Additional policies for Perl::Critic
perl-Perl-Critic-Tics-0.8.0-3-omv2015.0.noarch.rpm (this => is => not => good)
perl-Perl-Metrics-Simple-0.170.0-3-omv2015.0.noarch.rpm Methods analyzing a single file
perl-Perl-OSType-1.7.0-3-omv2015.0.noarch.rpm Map Perl operating system names to generic types
perl-Perl-PrereqScanner-1.15.0-3-omv2015.0.noarch.rpm A tool to scan your Perl code for its prerequisites
perl-Perl-Version-1.11.0-5-omv2015.0.noarch.rpm Parse and manipulate Perl version strings
perl-Perl6-Doc-0.470.0-5-omv2015.0.noarch.rpm Perl 6 Documentation Collection
perl-Perl6-Export-0.70.0-4-omv2015.0.noarch.rpm Implements the Perl 6 is export trait
perl-Perl6-Export-Attrs-0.0.3-5-omv2015.0.noarch.rpm The Perl 6 'is export(...)' trait as a Perl 5 attribute
perl-Perl6-Form-0.40.0-5-omv2015.0.noarch.rpm Implements the Perl 6 'form' built-in
Advertisement
Advertisement