denyhosts-2.6-3-omv4000.noarch.rpm


Advertisement

Description

denyhosts - A script to help thwart ssh server attacks

Property Value
Distribution OpenMandriva Lx 4.0
Repository OpenMandriva Unsupported Release x86_64
Package filename denyhosts-2.6-3-omv4000.noarch.rpm
Package name denyhosts
Package version 2.6
Package release 3-omv4000
Package architecture noarch
Package type rpm
Category Networking/Other
Homepage http://denyhosts.sourceforge.net/
License GPLv2
Maintainer -
Download size 59.47 KB
Installed size 191.08 KB
DenyHosts is a Python script that analyzes the sshd server log
messages to determine which hosts are attempting to hack into your
system. It also determines what user accounts are being targeted. It
keeps track of the frequency of attempts from each host and, upon
discovering a repeated attack host, updates the /etc/hosts.deny file
to prevent future break-in attempts from that host.  Email reports can
be sent to a system admin.

Alternatives

Package Version Architecture Repository
denyhosts-2.6-3-omv4000.noarch.rpm 2.6 noarch OpenMandriva Unsupported Release
denyhosts-2.6-3-omv2015.0.noarch.rpm 2.6 noarch OpenMandriva Unsupported Release
denyhosts-2.6-3-omv2015.0.noarch.rpm 2.6 noarch OpenMandriva Unsupported Release
denyhosts - - -

Requires

Name Value
/bin/bash -
/bin/env -
/usr/bin/env -
/usr/bin/python -
openssh-server -
python(abi) = 3.7
rpm-helper -

Provides

Name Value
config(denyhosts) = 2.6-3
denyhosts = 2.6-3
python3.7dist(denyhosts) = 2.6
python3dist(denyhosts) = 2.6
python3egg(denyhosts) = 2.6

Download

Type URL
Mirror abf-downloads.openmandriva.org
Binary Package denyhosts-2.6-3-omv4000.noarch.rpm
Source Package denyhosts-2.6-3.src.rpm

Install Howto

  1. Enable the repository in Software Repository Picker:
    # om-repo-picker
  2. Install denyhosts rpm package:
    # dnf --refresh install denyhosts

Files

Path
/etc/denyhosts.conf
/etc/cron.d/denyhosts
/etc/logrotate.d/denyhosts
/etc/rc.d/init.d/denyhosts
/etc/sysconfig/denyhosts
/usr/bin/denyhosts-control
/usr/bin/denyhosts.py
/usr/lib/python3.7/site-packages/DenyHosts-2.6-py3.7.egg-info
/usr/lib/python3.7/site-packages/DenyHosts/__init__.py
/usr/lib/python3.7/site-packages/DenyHosts/allowedhosts.py
/usr/lib/python3.7/site-packages/DenyHosts/constants.py
/usr/lib/python3.7/site-packages/DenyHosts/counter.py
/usr/lib/python3.7/site-packages/DenyHosts/daemon.py
/usr/lib/python3.7/site-packages/DenyHosts/deny_hosts.py
/usr/lib/python3.7/site-packages/DenyHosts/denyfileutil.py
/usr/lib/python3.7/site-packages/DenyHosts/filetracker.py
/usr/lib/python3.7/site-packages/DenyHosts/lockfile.py
/usr/lib/python3.7/site-packages/DenyHosts/loginattempt.py
/usr/lib/python3.7/site-packages/DenyHosts/old-daemon.py
/usr/lib/python3.7/site-packages/DenyHosts/plugin.py
/usr/lib/python3.7/site-packages/DenyHosts/prefs.py
/usr/lib/python3.7/site-packages/DenyHosts/purgecounter.py
/usr/lib/python3.7/site-packages/DenyHosts/python_version.py
/usr/lib/python3.7/site-packages/DenyHosts/regex.py
/usr/lib/python3.7/site-packages/DenyHosts/report.py
/usr/lib/python3.7/site-packages/DenyHosts/restricted.py
/usr/lib/python3.7/site-packages/DenyHosts/sync.py
/usr/lib/python3.7/site-packages/DenyHosts/util.py
/usr/lib/python3.7/site-packages/DenyHosts/version.py
/usr/lib/python3.7/site-packages/DenyHosts/__pycache__/__init__.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/DenyHosts/__pycache__/__init__.cpython-37.pyc
/usr/lib/python3.7/site-packages/DenyHosts/__pycache__/constants.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/DenyHosts/__pycache__/constants.cpython-37.pyc
/usr/lib/python3.7/site-packages/DenyHosts/__pycache__/counter.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/DenyHosts/__pycache__/counter.cpython-37.pyc
/usr/lib/python3.7/site-packages/DenyHosts/__pycache__/regex.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/DenyHosts/__pycache__/regex.cpython-37.pyc
/usr/lib/python3.7/site-packages/DenyHosts/__pycache__/report.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/DenyHosts/__pycache__/report.cpython-37.pyc
/usr/lib/python3.7/site-packages/DenyHosts/__pycache__/restricted.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/DenyHosts/__pycache__/restricted.cpython-37.pyc
/usr/lib/python3.7/site-packages/DenyHosts/__pycache__/version.cpython-37.opt-1.pyc
/usr/lib/python3.7/site-packages/DenyHosts/__pycache__/version.cpython-37.pyc
/usr/share/denyhosts/
/usr/share/denyhosts/plugins/shorewall_allow.sh
/usr/share/denyhosts/plugins/shorewall_deny.sh
/usr/share/denyhosts/plugins/test_deny.py
/usr/share/denyhosts/scripts/restricted_from_invalid.py
/usr/share/denyhosts/scripts/restricted_from_passwd.py
/usr/share/doc/denyhosts/CHANGELOG.txt
/usr/share/doc/denyhosts/LICENSE.txt
/usr/share/doc/denyhosts/README.contrib
/usr/share/doc/denyhosts/README.fedora
/usr/share/doc/denyhosts/README.txt
/usr/share/doc/denyhosts/denyhosts.cfg-dist
/usr/share/doc/denyhosts/setup.py
/var/lib/denyhosts/allowed-hosts
/var/lib/denyhosts/allowed-warned-hosts
/var/lib/denyhosts/hosts
/var/lib/denyhosts/hosts-restricted
/var/lib/denyhosts/hosts-root
/var/lib/denyhosts/hosts-valid
/var/lib/denyhosts/offset
/var/lib/denyhosts/suspicious-logins
/var/lib/denyhosts/sync-hosts
/var/lib/denyhosts/users-hosts
/var/lib/denyhosts/users-invalid
/var/lib/denyhosts/users-valid
/var/log/denyhosts

See Also

Package Description
deskolo-0.23-5-omv2015.0.x86_64.rpm Energy consumption monitoring utilities
deskolo-0.23-5-omv4000.x86_64.rpm Energy consumption monitoring utilities
desktopcouch-1.0.7-3-omv4000.noarch.rpm Integration of CouchDB storage into desktop applications
desktopcouch-tools-1.0.7-3-omv4000.noarch.rpm Desktopcouch tools
desmume-0.9.10-2-omv2015.0.x86_64.rpm A Nintendo DS emulator
desmume-cli-0.9.10-2-omv2015.0.x86_64.rpm A Nintendo DS emulator (CLI version)
desmume-glade-0.9.10-2-omv2015.0.x86_64.rpm A Nintendo DS emulator (Glade GUI version)
deutex-4.4.0-4-omv2013.0.x86_64.rpm Summary A utility for modifying the graphics of Doom IWAD and PWAD files
devede-4.14.0-1-omv4000.noarch.rpm Graphical frontend to create video DVDs/(S)VCDs
devicesync-0.1-3-omv2015.0.x86_64.rpm An application that lets you transfer data between devices
devicesync-devel-0.1-3-omv2015.0.x86_64.rpm Header files and documentation for compiling devicesync applications
devil-old-utils-1.7.8-14-omv2015.0.x86_64.rpm Tools provided by DevIL
devil-utils-1.7.8-13-omv2015.0.x86_64.rpm Tools provided by DevIL
devilspie-0.23-2-omv2015.0.x86_64.rpm A window matching tool
devilspie-0.23-2-omv4000.x86_64.rpm A window matching tool
Advertisement
Advertisement