llvm-polly-5.0.2-1-omv2015.0.i586.rpm


Advertisement

Description

llvm-polly - Polyhedral optimizations for LLVM

Property Value
Distribution OpenMandriva Lx 3.0
Repository OpenMandriva Main Updates i586
Package filename llvm-polly-5.0.2-1-omv2015.0.i586.rpm
Package name llvm-polly
Package version 5.0.2
Package release 1-omv2015.0
Package architecture i586
Package type rpm
Category Development/Other
Homepage http://llvm.org/
License MIT
Maintainer -
Download size 1.12 MB
Installed size 5.58 MB
Polly is a polyhedral optimizer for LLVM.
Using an abstract mathematical representation it analyzes and optimizes
the memory access pattern of a program. This includes data-locality
optimizations for cache locality as well as automatic parallelization
for thread-level and SIMD parallelism.
Our overall goal is an integrated optimizer for data-locality and
parallelism that takes advantage of multi-cores, cache hierarchies,
short vector instructions as well as dedicated accelerators.

Alternatives

Package Version Architecture Repository
llvm-polly-5.0.2-1-omv2015.0.x86_64.rpm 5.0.2 x86_64 OpenMandriva Main Updates
llvm-polly-4.0.1-1-omv2015.0.x86_64.rpm 4.0.1 x86_64 OpenMandriva Main Updates
llvm-polly-3.8.1-1.1-omv2015.0.x86_64.rpm 3.8.1 x86_64 OpenMandriva Main Release
llvm-polly-3.8.0-5.270146.1-omv2015.0.i586.rpm 3.8.0 i586 OpenMandriva Main Release
llvm-polly-3.8.0-5.265380.1-omv2015.0.x86_64.rpm 3.8.0 x86_64 OpenMandriva Main Release
llvm-polly-3.8.0-3-omv2015.0.i586.rpm 3.8.0 i586 OpenMandriva Main Release
llvm-polly - - -

Requires

Name Value
ld-linux.so.2 -
ld-linux.so.2(GLIBC_2.3) -
libLLVMAnalysis.so.5.0 -
libLLVMCore.so.5.0 -
libLLVMInstCombine.so.5.0 -
libLLVMMC.so.5.0 -
libLLVMNVPTXCodeGen.so.5.0 -
libLLVMNVPTXDesc.so.5.0 -
libLLVMNVPTXInfo.so.5.0 -
libLLVMScalarOpts.so.5.0 -
libLLVMSupport.so.5.0 -
libLLVMTransformUtils.so.5.0 -
libLLVMipo.so.5.0 -
libc.so.6 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.3) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libgcc_s.so.1 -
libgcc_s.so.1(GLIBC_2.0) -
libm.so.6 -
libm.so.6(GLIBC_2.0) -
libstdc++.so.6 -
libstdc++.so.6(CXXABI_1.3) -
libstdc++.so.6(CXXABI_1.3.9) -
libstdc++.so.6(GLIBCXX_3.4) -
libstdc++.so.6(GLIBCXX_3.4.11) -
libstdc++.so.6(GLIBCXX_3.4.14) -
libstdc++.so.6(GLIBCXX_3.4.15) -
libstdc++.so.6(GLIBCXX_3.4.21) -
libstdc++.so.6(GLIBCXX_3.4.5) -

Provides

Name Value
LLVMPolly.so -
libPolly.so -
libPollyISL.so -
libPollyPPCG.so -
llvm-polly == 5.0.2-1:2015.0

Conflicts

Name Value
libllvm-devel < 4.0.1

Obsoletes

Name Value
libllvm-devel < 4.0.1
llvm-devel < 4.0.1

Download

Type URL
Mirror abf-downloads.openmandriva.org
Binary Package llvm-polly-5.0.2-1-omv2015.0.i586.rpm
Source Package llvm-5.0.2-1.src.rpm

Install Howto

  1. Enable OpenMandriva Main Updates repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install llvm-polly rpm package:
    # urpmi llvm-polly

Files

Path
/usr/bin/pollyc++
/usr/bin/pollycc
/usr/lib/LLVMPolly.so
/usr/lib/libPolly.so
/usr/lib/libPollyISL.so
/usr/lib/libPollyPPCG.so
/usr/share/man/man1/polly.1.xz

See Also

Package Description
llvm-polly-devel-5.0.2-1-omv2015.0.i586.rpm Development files for Polly
locales-2.27-9-omv2015.0.i586.rpm Base files for localization
locales-aa-2.27-9-omv2015.0.i586.rpm Base files for localization (Afar)
locales-af-2.27-9-omv2015.0.i586.rpm Base files for localization (Afrikaans)
locales-agr-2.27-9-omv2015.0.i586.rpm Base files for localization (Aguaruna)
locales-ak-2.27-9-omv2015.0.i586.rpm Base files for localization (Akan)
locales-am-2.27-9-omv2015.0.i586.rpm Base files for localization (Amharic)
locales-anp-2.27-9-omv2015.0.i586.rpm Base files for localization (Angika)
locales-ar-2.27-9-omv2015.0.i586.rpm Base files for localization (Arabic)
locales-as-2.27-9-omv2015.0.i586.rpm Base files for localization (Assamese)
locales-ast-2.27-9-omv2015.0.i586.rpm Base files for localization (Asturian)
locales-ayc-2.27-9-omv2015.0.i586.rpm Base files for localization (Aymara)
locales-az-2.27-9-omv2015.0.i586.rpm Base files for localization (Azeri)
locales-be-2.27-9-omv2015.0.i586.rpm Base files for localization (Belarusian)
locales-bem-2.27-9-omv2015.0.i586.rpm Base files for localization (Bemba)
Advertisement
Advertisement