php-cgi-7.0.6-2-omv2015.0.x86_64.rpm


Advertisement

Description

php-cgi - PHP7 CGI interface

Property Value
Distribution OpenMandriva Lx 3.0
Repository OpenMandriva Main Release x86_64
Package name php-cgi
Package version 7.0.6
Package release 2-omv2015.0
Package architecture x86_64
Package type rpm
Installed size 65.94 KB
Download size 30.26 KB
Official Mirror abf-downloads.openmandriva.org
PHP7 is an HTML-embeddable scripting language. PHP7 offers built-in database
integration for several commercial and non-commercial database management
systems, so writing a database-enabled script with PHP7 is fairly simple. The
most common use of PHP7 coding is probably as a replacement for CGI scripts.
This package contains a standalone (CGI) version of php with FastCGI support.
You must also install libphp7_common. If you need apache module support, you
also need to install the apache-mod_php package.

Alternatives

Package Version Architecture Repository
php-cgi-7.2.10-1-omv2015.0.i586.rpm 7.2.10 i586 OpenMandriva Main Testing
php-cgi-7.2.10-1-omv2015.0.x86_64.rpm 7.2.10 x86_64 OpenMandriva Main Testing
php-cgi-7.2.3-1-omv2015.0.i586.rpm 7.2.3 i586 OpenMandriva Main Updates
php-cgi-7.2.3-1-omv2015.0.x86_64.rpm 7.2.3 x86_64 OpenMandriva Main Updates
php-cgi-7.0.9-1-omv2015.0.i586.rpm 7.0.9 i586 OpenMandriva Main Release
php-cgi-7.0.9-1-omv2015.0.x86_64.rpm 7.0.9 x86_64 OpenMandriva Main Release
php-cgi-7.0.6-2-omv2015.0.i586.rpm 7.0.6 i586 OpenMandriva Main Release
php-cgi - - -

Requires

Name Value
lib64php7_common5 >= 3:7.0.6-2:2015.0
libc.so.6()(64bit) -
libc.so.6(GLIBC_2.14)(64bit) -
libc.so.6(GLIBC_2.2.5)(64bit) -
libc.so.6(GLIBC_2.3)(64bit) -
libc.so.6(GLIBC_2.3.4)(64bit) -
libc.so.6(GLIBC_2.4)(64bit) -
libphp7_common.so.5()(64bit) -
php-ctype >= 3:7.0.6-2:2015.0
php-filter >= 3:7.0.6-2:2015.0
php-ftp >= 3:7.0.6-2:2015.0
php-gettext >= 3:7.0.6-2:2015.0
php-hash >= 3:7.0.6-2:2015.0
php-ini >= 7.0.6
php-json >= 3:7.0.6-2:2015.0
php-openssl >= 3:7.0.6-2:2015.0
php-posix >= 3:7.0.6-2:2015.0
php-session >= 3:7.0.6-2:2015.0
php-sysvsem >= 3:7.0.6-2:2015.0
php-sysvshm >= 3:7.0.6-2:2015.0
php-timezonedb >= 3:2009.10
php-tokenizer >= 3:7.0.6-2:2015.0
php-xml >= 3:7.0.6-2:2015.0
php-xmlreader >= 3:7.0.6-2:2015.0
php-xmlwriter >= 3:7.0.6-2:2015.0
php-zlib >= 3:7.0.6-2:2015.0

Provides

Name Value
php == 3:7.0.6-2:2015.0
php-cgi == 3:7.0.6-2:2015.0
php-fcgi == 3:7.0.6-2:2015.0

Conflicts

Name Value
php-fcgi < 3:7.0.6-2:2015.0

Obsoletes

Name Value
php-fcgi -

Download

Type URL
Binary Package php-cgi-7.0.6-2-omv2015.0.x86_64.rpm
Source Package php-7.0.6-2.src.rpm

Install Howto

  1. Enable OpenMandriva Main Release repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install php-cgi rpm package:
    # urpmi php-cgi

Files

Path
/usr/bin/php-cgi
/usr/bin/php-fcgi
/usr/share/doc/php-cgi/CREDITS.cgi
/usr/share/doc/php-cgi/README.fcgi
/usr/share/man/man1/php-cgi.1.xz

See Also

Package Description
php-cli-7.0.6-2-omv2015.0.x86_64.rpm PHP7 CLI interface
php-cli-7.0.9-1-omv2015.0.x86_64.rpm PHP7 CLI interface
php-ctype-7.0.6-2-omv2015.0.x86_64.rpm Ctype extension module for PHP
php-ctype-7.0.9-1-omv2015.0.x86_64.rpm Ctype extension module for PHP
php-cups-2.0.3-4-omv2015.0.x86_64.rpm PHP bindings for the libcups library
php-cups-2.1.3-1-omv2015.0.x86_64.rpm PHP bindings for the libcups library
php-curl-7.0.6-2-omv2015.0.x86_64.rpm Curl extension module for PHP
php-curl-7.0.9-1-omv2015.0.x86_64.rpm Curl extension module for PHP
php-dba-7.0.6-2-omv2015.0.x86_64.rpm DBA extension module for PHP
php-dba-7.0.9-1-omv2015.0.x86_64.rpm DBA extension module for PHP
php-dbg-7.0.6-2-omv2015.0.x86_64.rpm Debugging version of the PHP7 CLI interface
php-dbg-7.0.9-1-omv2015.0.x86_64.rpm Debugging version of the PHP7 CLI interface
php-devel-7.0.6-2-omv2015.0.x86_64.rpm Development package for PHP7
php-devel-7.0.9-1-omv2015.0.x86_64.rpm Development package for PHP7
php-doc-7.0.6-2-omv2015.0.x86_64.rpm Documentation for PHP
Advertisement
Advertisement