perl-PadWalker-2.0.0-2-omv2015.0.i586.rpm


Advertisement

Description

perl-PadWalker - Play with other peoples' lexical variables

Property Value
Distribution OpenMandriva Lx 3.0
Repository OpenMandriva Main Release i586
Package filename perl-PadWalker-2.0.0-2-omv2015.0.i586.rpm
Package name perl-PadWalker
Package version 2.0.0
Package release 2-omv2015.0
Package architecture i586
Package type rpm
Category Development/Perl
Homepage http://search.cpan.org/dist/PadWalker/
License Artistic/GPLv2
Maintainer -
Download size 20.00 KB
Installed size 35.61 KB
PadWalker is a module which allows you to inspect (and even change!) lexical
variables in any subroutine which called you. It will only show those variables
which are in scope at the point of the call.

Alternatives

Package Version Architecture Repository
perl-PadWalker-2.0.0-2-omv2015.0.x86_64.rpm 2.0.0 x86_64 OpenMandriva Main Release
perl-PadWalker - - -

Requires

Name Value
libc.so.6 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.3.4) -
libperl.so.5.20 -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
perl(DynaLoader) -
perl(Exporter) -
perl(abi) >= 5.20.2

Provides

Name Value
PadWalker.so -
perl(PadWalker) == 2.0.0
perl-PadWalker == 2.0.0-2:2015.0

Download

Type URL
Mirror abf-downloads.openmandriva.org
Binary Package perl-PadWalker-2.0.0-2-omv2015.0.i586.rpm
Source Package perl-PadWalker-2.0.0-2.src.rpm

Install Howto

  1. Enable OpenMandriva Main Release repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install perl-PadWalker rpm package:
    # urpmi perl-PadWalker

Files

Path
/usr/lib/perl5/vendor_perl/5.20.2/i386-linux-thread-multi/PadWalker.pm
/usr/lib/perl5/vendor_perl/5.20.2/i386-linux-thread-multi/auto/PadWalker/PadWalker.so
/usr/share/doc/perl-PadWalker/Changes
/usr/share/doc/perl-PadWalker/README
/usr/share/man/man3/PadWalker.3pm.xz

Changelog

2015-07-19 - Bernhard Rosenkraenzer <bero@bero.eu> 2.0.0-2
- (6c1e2f9) MassBuild#774: Increase release tag

See Also

Package Description
perl-Pango-1.227.0-1-omv2015.0.i586.rpm Perl module for the Pango library
perl-Pango-doc-1.227.0-1-omv2015.0.i586.rpm Pango documentation
perl-Parallel-Iterator-1.00-15-omv2015.0.noarch.rpm Simple parallel execution
perl-Params-Check-0.280.0-6-omv2015.0.noarch.rpm A generic input parsing/checking mechanism
perl-Params-Classify-0.13.0-12-omv2015.0.i586.rpm Argument type classification
perl-Params-Util-1.70.0-16-omv2015.0.i586.rpm Simple standalone param-checking functions
perl-Params-Validate-1.130.0-8-omv2015.0.i586.rpm Validate method/function call parameters
perl-Parse-EDID-1.0.6-8-omv2015.0.noarch.rpm Extended display identification data (EDID) parser
perl-Parse-RecDescent-1.967.9-6-omv2015.0.noarch.rpm A recursive descent parser generator for Perl
perl-Parse-Yapp-1.50.0-16-omv2015.0.noarch.rpm Fully reentrant perl OO LALR(1) parser creator
perl-PathTools-3.470.0-4-omv2015.0.i586.rpm Tools for working with paths and file specs across platforms
perl-Period-1.200.0-15-omv2015.0.noarch.rpm Time::Period module for perl
perl-Perl-Critic-1.123.0-2-omv2015.0.noarch.rpm Critique Perl source for style and standards
perl-Perl-MinimumVersion-1.380.0-4-omv2015.0.noarch.rpm Find a minimum required version of perl for Perl code
perl-PerlIO-gzip-0.180.0-17-omv2015.0.i586.rpm Perl extension to provide a PerlIO layer to gzip/gunzip
Advertisement
Advertisement