python-elixir-0.7.1-2-omv2015.0.noarch.rpm


Advertisement

Description

python-elixir - Declarative mapper on top of SQLAlchemy

Distribution: OpenMandriva Lx 3.0
Repository: OpenMandriva Contrib i586
Package name: python-elixir
Package version: 0.7.1
Package release: 2-omv2015.0
Package architecture: noarch
Package type: rpm
Installed size: 183.80 KB
Download size: 45.58 KB
Official Mirror: abf-downloads.openmandriva.org
A declarative layer on top of SQLAlchemy. It is a fairly thin wrapper, which provides the ability to create simple Python classes that map directly to relational database tables (this pattern is often referred to as the Active Record design pattern), providing many of the benefits of traditional databases without losing the convenience of Python objects. Elixir is intended to replace the ActiveMapper SQLAlchemy extension, and the TurboEntity project but does not intend to replace SQLAlchemy's core features, and instead focuses on providing a simpler syntax for defining model objects when you do not need the full expressiveness of SQLAlchemy's manual mapper definitions.

Alternatives

Provides

  • python-elixir == 0.7.1-2:2015.0
  • python3egg(elixir) == 0.7.1

    Install Howto

    1. Enable OpenMandriva Contrib repository on Install and Remove Software"
    2. Update packages list:
      # urpmi.update -a
    3. Install python-elixir rpm package:
      # urpmi python-elixir

    Files

    • /usr/lib/python3.4/site-packages/Elixir-0.7.1-py3.4.egg-info/PKG-INFO
    • /usr/lib/python3.4/site-packages/Elixir-0.7.1-py3.4.egg-info/SOURCES.txt
    • /usr/lib/python3.4/site-packages/Elixir-0.7.1-py3.4.egg-info/dependency_links.txt
    • /usr/lib/python3.4/site-packages/Elixir-0.7.1-py3.4.egg-info/requires.txt
    • /usr/lib/python3.4/site-packages/Elixir-0.7.1-py3.4.egg-info/top_level.txt
    • /usr/lib/python3.4/site-packages/elixir/__init__.py
    • /usr/lib/python3.4/site-packages/elixir/collection.py
    • /usr/lib/python3.4/site-packages/elixir/entity.py
    • /usr/lib/python3.4/site-packages/elixir/events.py
    • /usr/lib/python3.4/site-packages/elixir/fields.py
    • /usr/lib/python3.4/site-packages/elixir/options.py
    • /usr/lib/python3.4/site-packages/elixir/properties.py
    • /usr/lib/python3.4/site-packages/elixir/py23compat.py
    • /usr/lib/python3.4/site-packages/elixir/relationships.py
    • /usr/lib/python3.4/site-packages/elixir/statements.py
    • /usr/lib/python3.4/site-packages/elixir/ext/__init__.py
    • /usr/lib/python3.4/site-packages/elixir/ext/associable.py
    • /usr/lib/python3.4/site-packages/elixir/ext/encrypted.py
    • /usr/lib/python3.4/site-packages/elixir/ext/list.py
    • /usr/lib/python3.4/site-packages/elixir/ext/perform_ddl.py
    • /usr/lib/python3.4/site-packages/elixir/ext/versioned.py
    • /usr/share/doc/python-elixir/README
    Advertisement
    Advertisement