python-dparser-1.30-1-omv2014.1.i586.rpm


Advertisement

Description

python-dparser - DParser python binding

Property Value
Distribution OpenMandriva Lx 3.0
Repository OpenMandriva Contrib i586
Package name python-dparser
Package version 1.30
Package release 1-omv2014.1
Package architecture i586
Package type rpm
Installed size 486.51 KB
Download size 136.75 KB
Official Mirror abf-downloads.openmandriva.org
DParser is a simple but powerful tool for parsing, written by J. Plevyak.
DParser for Python gives Python programmers a seamless interface to DParser.
The features that set this Python parser apart from other Python parsers are:
+ it can deal with any grammar (GLR)
+ it is fast (based in C)
+ it does not require a compiler to operate.
DParser for Python also has many easy-to-use features found in other Python
parsers:
+ it does not require explicit definitions of tokens
+ it does not require a separate, non-Python grammar file
+ it uses function documentation strings to specify grammar rules
+ it does not output parser code that the user must compile or run.

Alternatives

Package Version Architecture Repository
python-dparser-1.30-1-omv2014.1.x86_64.rpm 1.30 x86_64 OpenMandriva Contrib
python-dparser - - -

Requires

Name Value
libc.so.6 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.3) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libpython2.7.so.1.0 -
python -
python(abi) == 2.7

Provides

Name Value
_dparser_swigc.so -
python-dparser == 1.30-1:2014.1
pythonegg(dparser) == 1.30

Download

Type URL
Binary Package python-dparser-1.30-1-omv2014.1.i586.rpm
Source Package dparser-1.30-1.src.rpm

Install Howto

  1. Enable OpenMandriva Contrib repository on Install and Remove Software"
  2. Update packages list:
    # urpmi.update -a
  3. Install python-dparser rpm package:
    # urpmi python-dparser

Files

Path
/usr/lib/python2.7/site-packages/_dparser_swigc.so
/usr/lib/python2.7/site-packages/dparser-1.30-py2.7.egg-info
/usr/lib/python2.7/site-packages/dparser.py
/usr/lib/python2.7/site-packages/dparser_swigc.py
/usr/share/doc/python-dparser/README
/usr/share/doc/python-dparser/calc.py
/usr/share/doc/python-dparser/index.html
/usr/share/doc/python-dparser/py_dparser_manual.html
/usr/share/doc/python-dparser/contrib/dparserpy-syntax_error.py
/usr/share/doc/python-dparser/contrib/dparserpy.el
/usr/share/doc/python-dparser/tests/test.py
/usr/share/doc/python-dparser/tests/test2.py
/usr/share/doc/python-dparser/tests/test3.py
/usr/share/doc/python-dparser/tests/test4.py
/usr/share/doc/python-dparser/tests/test5.py
/usr/share/doc/python-dparser/tests/test6.py
/usr/share/doc/python-dparser/tests/test7.py

Changelog

2014-05-15 - Denis Silakov <denis.silakov@rosalab.ru> 1.30-1
+ Revision: 2cfa6af
- Added rpmlintrc

See Also

Package Description
python-dtopt-0.1-3-omv2015.0.noarch.rpm Add options to doctest examples while they are running
python-dulwich-0.9.6-1-omv2014.1.i586.rpm Python implementation of the Git file formats and protocols
python-ecasound-2.9.1-1-omv2015.0.i586.rpm Python bindings to ecasound control interface
python-ecryptfs-utils-103-1-omv2013.0.i586.rpm eCryptfs Python library
python-efl-1.9.0-1-omv2014.1.i586.rpm EFL bindings for Python
python-elib.intl-0.0.3-0.20110711.1-omv2015.0.noarch.rpm Enhanced internationalization (I18N) for Python
python-elixir-0.7.1-2-omv2015.0.noarch.rpm Declarative mapper on top of SQLAlchemy
python-enable-4.2.0-3-omv2013.0.i586.rpm Enthought Tool Suite - low-level drawing and interaction
python-enaml-0.6.8-1-omv2013.0.noarch.rpm ETS declarative language for building dynamic user interfaces
python-envisage-4.3.0-1-omv2013.0.noarch.rpm Enthought Tool Suite - extensible application framework
python-ephem-3.7.5.2-1-omv2014.1.i586.rpm Scientific-grade astronomical computations for python
python-ets-4.3.0-1-omv2013.0.noarch.rpm Enthought Tool Suite
python-etsdevtools-4.0.2-1-omv2013.0.noarch.rpm Enthought Tool Suite - etsdevtools project
python-etsproxy-0.1.2-1-omv2013.0.noarch.rpm Enthought Tool Suite - proxy modules for backwards compatibility
python-eventlet-0.14.0-1-omv2014.1.noarch.rpm Highly concurrent networking library
Advertisement
Advertisement