perl-UI-Dialog-1.80.0-6-omv2015.0.noarch.rpm


Advertisement

Description

perl-UI-Dialog - OOPerl wrapper for the various dialog applications

Distribution: OpenMandriva Lx 3.0
Repository: OpenMandriva Contrib i586
Package name: perl-UI-Dialog
Package version: 1.80.0
Package release: 6-omv2015.0
Package architecture: noarch
Package type: rpm
Installed size: 558.33 KB
Download size: 110.21 KB
Official Mirror: abf-downloads.openmandriva.org
UI::Dialog is a OOPerl wrapper for the various dialog applications. These dialog backends are currently supported: Zenity, GDialog, XDialog, KDialog, CDialog, and Whiptail. There is also an ASCII backend provided as a last resort interface for the console based dialog variants. UI::Dialog is a class that provides a strict interface to these various backend modules. By using UI:Dialog (with it's imposed limitations on the widgets) you can ensure that your Perl program will function with any available interfaces. UI::Dialog supports priority ordering of the backend detection process. So if you'd prefer that Xdialog should be used first if available, simply designate the desired order when creating the new object. The default order for detecting and utilization of the backends are as follows: (with DISPLAY env): Zenity, GDialog, XDialog, KDialog (without DISPLAY): CDialog, Whiptail, ASCII UI::Dialog is the result of a complete re-write of the UDPM CPAN module. This was done to break away from the bad choice of name (UserDialogPerlModule) and to implement a cleaner, more detached, OOPerl interface.

Alternatives

Provides

  • perl(UI::Dialog) == 1.80.0
  • perl(UI::Dialog::Backend) == 1.80.0
  • perl(UI::Dialog::Backend::ASCII) == 1.80.0
  • perl(UI::Dialog::Backend::CDialog) == 1.80.0
  • perl(UI::Dialog::Backend::GDialog) == 1.80.0
  • perl(UI::Dialog::Backend::KDialog) == 1.80.0
  • perl(UI::Dialog::Backend::Nautilus) == 1.80.0
  • perl(UI::Dialog::Backend::Whiptail) == 1.80.0
  • perl(UI::Dialog::Backend::XDialog) == 1.80.0
  • perl(UI::Dialog::Backend::XOSD) == 1.80.0
  • perl(UI::Dialog::Backend::Zenity) == 1.80.0
  • perl(UI::Dialog::Console) == 1.80.0
  • perl(UI::Dialog::GNOME) == 1.80.0
  • perl(UI::Dialog::Gauged) == 1.80.0
  • perl(UI::Dialog::KDE) == 1.80.0
  • perl-UI-Dialog == 1.80.0-6:2015.0

    Install Howto

    1. Enable OpenMandriva Contrib repository on Install and Remove Software"
    2. Update packages list:
      # urpmi.update -a
    3. Install perl-UI-Dialog rpm package:
      # urpmi perl-UI-Dialog

    Files

    • /usr/lib/perl5/vendor_perl/5.20.1/UI/Dialog.pm
    • /usr/lib/perl5/vendor_perl/5.20.1/UI/Dialog.pod
    • /usr/lib/perl5/vendor_perl/5.20.1/UI/Dialog/Backend.pm
    • /usr/lib/perl5/vendor_perl/5.20.1/UI/Dialog/Backend.pod
    • /usr/lib/perl5/vendor_perl/5.20.1/UI/Dialog/Console.pm
    • /usr/lib/perl5/vendor_perl/5.20.1/UI/Dialog/Console.pod
    • /usr/lib/perl5/vendor_perl/5.20.1/UI/Dialog/GNOME.pm
    • /usr/lib/perl5/vendor_perl/5.20.1/UI/Dialog/GNOME.pod
    • /usr/lib/perl5/vendor_perl/5.20.1/UI/Dialog/Gauged.pm
    • /usr/lib/perl5/vendor_perl/5.20.1/UI/Dialog/Gauged.pod
    • /usr/lib/perl5/vendor_perl/5.20.1/UI/Dialog/KDE.pm
    • /usr/lib/perl5/vendor_perl/5.20.1/UI/Dialog/KDE.pod
    • /usr/lib/perl5/vendor_perl/5.20.1/UI/Dialog/Backend/ASCII.pm
    • /usr/lib/perl5/vendor_perl/5.20.1/UI/Dialog/Backend/ASCII.pod
    • /usr/lib/perl5/vendor_perl/5.20.1/UI/Dialog/Backend/CDialog.pm
    • /usr/lib/perl5/vendor_perl/5.20.1/UI/Dialog/Backend/CDialog.pod
    • /usr/lib/perl5/vendor_perl/5.20.1/UI/Dialog/Backend/GDialog.pm
    • /usr/lib/perl5/vendor_perl/5.20.1/UI/Dialog/Backend/GDialog.pod
    • /usr/lib/perl5/vendor_perl/5.20.1/UI/Dialog/Backend/KDialog.pm
    • /usr/lib/perl5/vendor_perl/5.20.1/UI/Dialog/Backend/KDialog.pod
    • /usr/lib/perl5/vendor_perl/5.20.1/UI/Dialog/Backend/Nautilus.pm
    • /usr/lib/perl5/vendor_perl/5.20.1/UI/Dialog/Backend/Nautilus.pod
    • /usr/lib/perl5/vendor_perl/5.20.1/UI/Dialog/Backend/Whiptail.pm
    • /usr/lib/perl5/vendor_perl/5.20.1/UI/Dialog/Backend/Whiptail.pod
    • /usr/lib/perl5/vendor_perl/5.20.1/UI/Dialog/Backend/XDialog.pm
    • /usr/lib/perl5/vendor_perl/5.20.1/UI/Dialog/Backend/XDialog.pod
    • /usr/lib/perl5/vendor_perl/5.20.1/UI/Dialog/Backend/XOSD.pm
    • /usr/lib/perl5/vendor_perl/5.20.1/UI/Dialog/Backend/XOSD.pod
    • /usr/lib/perl5/vendor_perl/5.20.1/UI/Dialog/Backend/Zenity.pm
    • /usr/lib/perl5/vendor_perl/5.20.1/UI/Dialog/Backend/Zenity.pod
    • /usr/share/doc/perl-UI-Dialog/CONTRIBUTORS
    • /usr/share/doc/perl-UI-Dialog/COPYRIGHT
    • /usr/share/doc/perl-UI-Dialog/Changes
    • /usr/share/doc/perl-UI-Dialog/README
    • /usr/share/doc/perl-UI-Dialog/TODO
    • /usr/share/doc/perl-UI-Dialog/examples/ascii.pl
    • /usr/share/doc/perl-UI-Dialog/examples/cdialog.pl
    • /usr/share/doc/perl-UI-Dialog/examples/console.pl
    • /usr/share/doc/perl-UI-Dialog/examples/gdialog.pl
    • /usr/share/doc/perl-UI-Dialog/examples/gnome.pl
    • /usr/share/doc/perl-UI-Dialog/examples/kde.pl
    • /usr/share/doc/perl-UI-Dialog/examples/kdialog.pl
    • /usr/share/doc/perl-UI-Dialog/examples/nautilus.pl
    • /usr/share/doc/perl-UI-Dialog/examples/ui-dialog.pl
    • /usr/share/doc/perl-UI-Dialog/examples/whiptail.pl
    • /usr/share/doc/perl-UI-Dialog/examples/xdialog.pl
    • /usr/share/doc/perl-UI-Dialog/examples/xosd.pl
    • /usr/share/doc/perl-UI-Dialog/examples/zenity.pl
    • /usr/share/man/man3/UI::Dialog.3pm.xz
    • /usr/share/man/man3/UI::Dialog::Backend.3pm.xz
    • /usr/share/man/man3/UI::Dialog::Backend::ASCII.3pm.xz
    • /usr/share/man/man3/UI::Dialog::Backend::CDialog.3pm.xz
    • /usr/share/man/man3/UI::Dialog::Backend::GDialog.3pm.xz
    • /usr/share/man/man3/UI::Dialog::Backend::KDialog.3pm.xz
    • /usr/share/man/man3/UI::Dialog::Backend::Nautilus.3pm.xz
    • /usr/share/man/man3/UI::Dialog::Backend::Whiptail.3pm.xz
    • /usr/share/man/man3/UI::Dialog::Backend::XDialog.3pm.xz
    • /usr/share/man/man3/UI::Dialog::Backend::XOSD.3pm.xz
    • /usr/share/man/man3/UI::Dialog::Backend::Zenity.3pm.xz
    • /usr/share/man/man3/UI::Dialog::Console.3pm.xz
    • /usr/share/man/man3/UI::Dialog::GNOME.3pm.xz
    • /usr/share/man/man3/UI::Dialog::Gauged.3pm.xz
    • /usr/share/man/man3/UI::Dialog::KDE.3pm.xz
    Advertisement
    Advertisement