perl-Perl-AtEndOfScope-0.30.0-4-omv2015.0.noarch.rpm


Advertisement

Description

perl-Perl-AtEndOfScope - Perl::AtEndOfScope - run some code when a variable goes out of scope

Property Value
Distribution OpenMandriva Lx 3.0
Repository OpenMandriva Contrib Release i586
Package name perl-Perl-AtEndOfScope
Package version 0.30.0
Package release 4-omv2015.0
Package architecture noarch
Package type rpm
Installed size 6.92 KB
Download size 8.29 KB
Official Mirror abf-downloads.openmandriva.org
It's often necessary to do some cleanup at the end of a scope. This
module creates a Perl object and executes arbitrary code when the object
goes out of scope.

Alternatives

Package Version Architecture Repository
perl-Perl-AtEndOfScope-0.30.0-4-omv2015.0.noarch.rpm 0.30.0 noarch OpenMandriva Contrib Release
perl-Perl-AtEndOfScope - - -

Requires

Name Value
perl(abi) >= 5.20.1

Provides

Name Value
perl(Perl::AtEndOfScope) == 0.30.0
perl-Perl-AtEndOfScope == 0.30.0-4:2015.0

Download

Type URL
Binary Package perl-Perl-AtEndOfScope-0.30.0-4-omv2015.0.noarch.rpm
Source Package perl-Perl-AtEndOfScope-0.30.0-4.src.rpm

Install Howto

  1. Enable OpenMandriva Contrib Release repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install perl-Perl-AtEndOfScope rpm package:
    # urpmi perl-Perl-AtEndOfScope

Files

Path
/usr/lib/perl5/vendor_perl/5.20.1/Perl/AtEndOfScope.pm
/usr/share/doc/perl-Perl-AtEndOfScope/Changes
/usr/share/doc/perl-Perl-AtEndOfScope/README
/usr/share/man/man3/Perl::AtEndOfScope.3pm.xz

See Also

Package Description
perl-Perl-BestPractice-0.01-9-omv2015.0.noarch.rpm Perl Best Practices, the (unofficial) companion module
perl-Perl-Critic-Bangs-1.100.0-3-omv2015.0.noarch.rpm Adding modifiers to a regular expression
perl-Perl-Critic-Compatibility-1.1.0-5-omv2015.0.noarch.rpm Don't allow three-argument open unless version of perl supports it
perl-Perl-Critic-Deprecated-1.119.0-3-omv2015.0.noarch.rpm Write C<$my_variable = 42> instead of C<$MyVariable = 42>
perl-Perl-Critic-Lax-0.10.0-3-omv2015.0.noarch.rpm Policies that let you slide on common exceptions
perl-Perl-Critic-More-1.3.0-3-omv2015.0.noarch.rpm Stop mixing long strings with code
perl-Perl-Critic-Nits-1.0.0-5-omv2015.0.noarch.rpm Policies of nits I like to pick
perl-Perl-Critic-PetPeeves-JTRAMMELL-0.40.0-3-omv2015.0.noarch.rpm Prohibit superfluous initializations
perl-Perl-Critic-Pulp-85.0.0-1-omv2014.1.noarch.rpm Don't use Foo:: style barewords
perl-Perl-Critic-Storable-0.10.0-5-omv2015.0.noarch.rpm Perl::Critic policy for using Storable
perl-Perl-Critic-StricterSubs-0.30.0-5-omv2015.0.noarch.rpm Perl::Critic plugin for stricter subroutine checks
perl-Perl-Critic-Swift-1.0.3-4-omv2015.0.noarch.rpm Additional policies for Perl::Critic
perl-Perl-Critic-Tics-0.8.0-3-omv2015.0.noarch.rpm (this => is => not => good)
perl-Perl-Metrics-Simple-0.170.0-3-omv2015.0.noarch.rpm Methods analyzing a single file
perl-Perl-OSType-1.7.0-3-omv2015.0.noarch.rpm Map Perl operating system names to generic types
Advertisement
Advertisement