perl-Catalyst-Plugin-Authentication-0.100.230-3-omv2015.0.noarch.rpm


Advertisement

Description

perl-Catalyst-Plugin-Authentication - Infrastructure plugin for the Catalyst authentication framework

Property Value
Distribution OpenMandriva Lx 3.0
Repository OpenMandriva Contrib Release i586
Package name perl-Catalyst-Plugin-Authentication
Package version 0.100.230
Package release 3-omv2015.0
Package architecture noarch
Package type rpm
Installed size 215.71 KB
Download size 80.60 KB
Official Mirror abf-downloads.openmandriva.org
The authentication plugin provides generic user support. It is the basis for
both authentication (checking the user is who they claim to be), and
authorization (allowing the user to do what the system authorises them to do).

Alternatives

Package Version Architecture Repository
perl-Catalyst-Plugin-Authentication-0.100.230-3-omv2015.0.noarch.rpm 0.100.230 noarch OpenMandriva Contrib Release
perl-Catalyst-Plugin-Authentication - - -

Requires

Name Value
perl(Carp) -
perl(Catalyst::Exception) -
perl(Class::Inspector) -
perl(Digest) -
perl(MRO::Compat) -
perl(Moose) -
perl(Scalar::Util) -
perl(String::RewritePrefix) -
perl(Tie::RefHash) -
perl(Try::Tiny) -
perl(abi) >= 5.20.1

Provides

Name Value
perl(Catalyst::Authentication::Credential::NoPassword) -
perl(Catalyst::Authentication::Credential::Password) -
perl(Catalyst::Authentication::Credential::Remote) -
perl(Catalyst::Authentication::Realm) -
perl(Catalyst::Authentication::Realm::Compatibility) -
perl(Catalyst::Authentication::Realm::Progressive) -
perl(Catalyst::Authentication::Store::Minimal) -
perl(Catalyst::Authentication::Store::Null) -
perl(Catalyst::Authentication::User) -
perl(Catalyst::Authentication::User::Hash) -
perl(Catalyst::Plugin::Authentication) == 0.100.230
perl(Catalyst::Plugin::Authentication::Credential::Password) -
perl(Catalyst::Plugin::Authentication::Store::Minimal) -
perl(Catalyst::Plugin::Authentication::User) -
perl(Catalyst::Plugin::Authentication::User::Hash) -
perl-Catalyst-Plugin-Authentication == 1:0.100.230-3:2015.0

Download

Type URL
Binary Package perl-Catalyst-Plugin-Authentication-0.100.230-3-omv2015.0.noarch.rpm
Source Package perl-Catalyst-Plugin-Authentication-0.100.230-3.src.rpm

Install Howto

  1. Enable OpenMandriva Contrib Release repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install perl-Catalyst-Plugin-Authentication rpm package:
    # urpmi perl-Catalyst-Plugin-Authentication

Files

Path
/usr/lib/perl5/vendor_perl/5.20.1/Catalyst/
/usr/lib/perl5/vendor_perl/5.20.1/Catalyst/Authentication/Realm.pm
/usr/lib/perl5/vendor_perl/5.20.1/Catalyst/Authentication/Store.pod
/usr/lib/perl5/vendor_perl/5.20.1/Catalyst/Authentication/User.pm
/usr/lib/perl5/vendor_perl/5.20.1/Catalyst/Authentication/Credential/NoPassword.pm
/usr/lib/perl5/vendor_perl/5.20.1/Catalyst/Authentication/Credential/Password.pm
/usr/lib/perl5/vendor_perl/5.20.1/Catalyst/Authentication/Credential/Remote.pm
/usr/lib/perl5/vendor_perl/5.20.1/Catalyst/Authentication/Realm/Compatibility.pm
/usr/lib/perl5/vendor_perl/5.20.1/Catalyst/Authentication/Realm/Progressive.pm
/usr/lib/perl5/vendor_perl/5.20.1/Catalyst/Authentication/Store/Minimal.pm
/usr/lib/perl5/vendor_perl/5.20.1/Catalyst/Authentication/Store/Null.pm
/usr/lib/perl5/vendor_perl/5.20.1/Catalyst/Authentication/User/Hash.pm
/usr/lib/perl5/vendor_perl/5.20.1/Catalyst/Plugin/Authentication.pm
/usr/lib/perl5/vendor_perl/5.20.1/Catalyst/Plugin/Authentication/Internals.pod
/usr/lib/perl5/vendor_perl/5.20.1/Catalyst/Plugin/Authentication/User.pm
/usr/lib/perl5/vendor_perl/5.20.1/Catalyst/Plugin/Authentication/Credential/Password.pm
/usr/lib/perl5/vendor_perl/5.20.1/Catalyst/Plugin/Authentication/Store/Minimal.pm
/usr/lib/perl5/vendor_perl/5.20.1/Catalyst/Plugin/Authentication/User/Hash.pm
/usr/share/doc/perl-Catalyst-Plugin-Authentication/Changes
/usr/share/doc/perl-Catalyst-Plugin-Authentication/README
/usr/share/man/man3/Catalyst::Authentication::Credential::NoPassword.3pm.xz
/usr/share/man/man3/Catalyst::Authentication::Credential::Password.3pm.xz
/usr/share/man/man3/Catalyst::Authentication::Credential::Remote.3pm.xz
/usr/share/man/man3/Catalyst::Authentication::Realm.3pm.xz
/usr/share/man/man3/Catalyst::Authentication::Realm::Compatibility.3pm.xz
/usr/share/man/man3/Catalyst::Authentication::Realm::Progressive.3pm.xz
/usr/share/man/man3/Catalyst::Authentication::Store.3pm.xz
/usr/share/man/man3/Catalyst::Authentication::Store::Minimal.3pm.xz
/usr/share/man/man3/Catalyst::Authentication::Store::Null.3pm.xz
/usr/share/man/man3/Catalyst::Authentication::User.3pm.xz
/usr/share/man/man3/Catalyst::Authentication::User::Hash.3pm.xz
/usr/share/man/man3/Catalyst::Plugin::Authentication.3pm.xz
/usr/share/man/man3/Catalyst::Plugin::Authentication::Credential::Password.3pm.xz
/usr/share/man/man3/Catalyst::Plugin::Authentication::Internals.3pm.xz
/usr/share/man/man3/Catalyst::Plugin::Authentication::Store::Minimal.3pm.xz
/usr/share/man/man3/Catalyst::Plugin::Authentication::User.3pm.xz
/usr/share/man/man3/Catalyst::Plugin::Authentication::User::Hash.3pm.xz

See Also

Package Description
perl-Catalyst-Plugin-Authentication-CDBI-0.100.0-5-omv2015.0.noarch.rpm CDBI Authentication for Catalyst
perl-Catalyst-Plugin-Authorization-Roles-0.90.0-4-omv2015.0.noarch.rpm Role based authorization for Catalyst based on Catalyst::Plugin::Authentication
perl-Catalyst-Plugin-AutoCRUD-1.110.731-3-omv2013.0.noarch.rpm Instant AJAX web front-end for DBIx::Class
perl-Catalyst-Plugin-Cache-0.120.0-3-omv2015.0.noarch.rpm Choose a cache backend based on key regexes
perl-Catalyst-Plugin-Cache-FastMmap-0.900.0-4-omv2015.0.noarch.rpm Mmap cache for Catalyst applications
perl-Catalyst-Plugin-Cache-Store-FastMmap-0.20.0-6-omv2015.0.noarch.rpm A thin wrapper for
perl-Catalyst-Plugin-Captcha-0.40.0-5-omv2015.0.noarch.rpm Create and validate Captcha for Catalyst
perl-Catalyst-Plugin-Compress-Zlib-0.60.0-3-omv2015.0.noarch.rpm Gzip response
perl-Catalyst-Plugin-ConfigLoader-0.340.0-1-omv2014.1.noarch.rpm Load config files of various types
perl-Catalyst-Plugin-CustomErrorMessage-0.60.0-5-omv2015.0.noarch.rpm Catalyst plugin to have more "cute" error message
perl-Catalyst-Plugin-DateTime-0.30.0-5-omv2015.0.noarch.rpm DateTime plugin for Catalyst
perl-Catalyst-Plugin-DefaultEnd-0.80.0-4-omv2015.0.noarch.rpm Sensible default end action for Catalyst
perl-Catalyst-Plugin-FillInForm-0.120.0-5-omv2015.0.noarch.rpm FillInForm for Catalyst
perl-Catalyst-Plugin-FormValidator-0.94.0-5-omv2015.0.noarch.rpm FormValidator for Catalyst
perl-Catalyst-Plugin-HTML-Widget-1.100.0-5-omv2015.0.noarch.rpm HTML Widget And Validation Framework
Advertisement
Advertisement