libsmapi2.4-devel-2.4.0-0.rc5.5-omv2015.0.i586.rpm


Advertisement

Description

libsmapi2.4-devel - MsgAPI for the Husky-Packages, development files

Property Value
Distribution OpenMandriva Lx 3.0
Repository OpenMandriva Contrib Release i586
Package name libsmapi2.4-devel
Package version 2.4.0
Package release 0.rc5.5-omv2015.0
Package architecture i586
Package type rpm
Installed size 452.85 KB
Download size 199.15 KB
Official Mirror abf-downloads.openmandriva.org
smapi is a modified message api for *.MSG, SQUISH (C) and JAM-Messagebase
formats. It is required for all other Husky-Software.
This Package holds the Development files. Only needed if you want to compile
other Husky-Packages.

Alternatives

Package Version Architecture Repository
libsmapi2.4-devel - - -

Requires

Name Value
libsmapi2.4 == 2.4.0-0.rc5.5

Provides

Name Value
devel(libsmapi) -
libsmapi-devel == 2.4.0-0.rc5.5
libsmapi2.4-devel == 2.4.0-0.rc5.5:2015.0
smapi-devel == 2.4.0-0.rc5.5

Download

Type URL
Binary Package libsmapi2.4-devel-2.4.0-0.rc5.5-omv2015.0.i586.rpm
Source Package smapi-2.4.0-0.rc5.5.src.rpm

Install Howto

  1. Enable OpenMandriva Contrib Release repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install libsmapi2.4-devel rpm package:
    # urpmi libsmapi2.4-devel

Files

Path
/usr/include/smapi/api_brow.h
/usr/include/smapi/api_jam.h
/usr/include/smapi/compiler.h
/usr/include/smapi/cvsdate.h
/usr/include/smapi/ffind.h
/usr/include/smapi/msgapi.h
/usr/include/smapi/patmat.h
/usr/include/smapi/prog.h
/usr/include/smapi/progprot.h
/usr/include/smapi/stamp.h
/usr/include/smapi/typedefs.h
/usr/include/smapi/unused.h
/usr/lib/libsmapi.a
/usr/lib/libsmapi.so

Changelog

2012-12-11 - Alex Burmashev <alex.burmashev@rosalab.ru> 2.4.0-0.rc5.5
+ Revision: bffe8b5
- merging with rosa2012.1 of project smapi

See Also

Package Description
libsmltk0-1.4.1-2-omv2015.0.i586.rpm Smltk library
libsnet-devel-1.0.0-2-omv2015.0.i586.rpm Static library and header files for the libsnet library
libsnet0-1.0.0-2-omv2015.0.i586.rpm The libsnet library
libsnet_p0-1.0.0-2-omv2015.0.i586.rpm The libsnet library
libsoci-devel-3.1.0-1-omv2013.0.i586.rpm C++ Database Access Library development files
libsoci3-3.1.0-1-omv2013.0.i586.rpm C++ Database Access Libraries
libsocketlock-0.2-7-omv2015.0.i586.rpm A library wraper for libc's bind() and connect() functions
libsofia-sip-devel-1.12.11-1-omv2013.0.i586.rpm Headers of sofia-sip for development
libsofia-sip-static-devel-1.12.11-1-omv2013.0.i586.rpm Static development files for sofia-sip
libsofia-sip0-1.12.11-1-omv2013.0.i586.rpm Sophia-sip library
libsoqt-devel-1.5.0-3-omv2013.0.i586.rpm Headers for developing programs that will use SoQt
libsoqt-devel-1.5.0-6-omv2015.0.i586.rpm Headers for developing programs that will use SoQt
libsoqt20-1.5.0-3-omv2013.0.i586.rpm Main library for SoQt
libsoqt20-1.5.0-6-omv2015.0.i586.rpm Main library for SoQt
libsord-devel-0.14.0-1-omv2015.0.i586.rpm Headers for the sord RDF storage library
Advertisement
Advertisement