libdevil-old-devel-1.7.8-14-omv2015.0.i586.rpm


Advertisement

Description

libdevil-old-devel - Development headers and libraries for writing programs using DevIL

Distribution: OpenMandriva Lx 3.0
Repository: OpenMandriva Contrib i586
Package name: libdevil-old-devel
Package version: 1.7.8
Package release: 14-omv2015.0
Package architecture: i586
Package type: rpm
Installed size: 125.11 KB
Download size: 55.21 KB
Official Mirror: abf-downloads.openmandriva.org
Development headers and libraries for writing programs using DevIL.

Alternatives

Provides

  • devel(libIL)
  • devel(libILU)
  • devel(libILUT)
  • devil-old-devel == 1.7.8-14:2015.0
  • libdevil-old-devel == 1.7.8-14:2015.0
  • pkgconfig(IL) == 1.7.8
  • pkgconfig(ILU) == 1.7.8
  • pkgconfig(ILUT) == 1.7.8

Obsoletes

  • libdevel-static-devel == 1.7.8-14

    Install Howto

    1. Enable OpenMandriva Contrib repository on Install and Remove Software"
    2. Update packages list:
      # urpmi.update -a
    3. Install libdevil-old-devel rpm package:
      # urpmi libdevil-old-devel

    Files

    • /usr/include/IL/devil_cpp_wrapper.hpp
    • /usr/include/IL/il.h
    • /usr/include/IL/ilu.h
    • /usr/include/IL/ilu_region.h
    • /usr/include/IL/ilut.h
    • /usr/lib/libIL.so
    • /usr/lib/libILU.so
    • /usr/lib/libILUT.so
    • /usr/lib/pkgconfig/IL.pc
    • /usr/lib/pkgconfig/ILU.pc
    • /usr/lib/pkgconfig/ILUT.pc
    • /usr/share/doc/libdevil-old-devel/AUTHORS
    • /usr/share/doc/libdevil-old-devel/CREDITS
    • /usr/share/doc/libdevil-old-devel/ChangeLog
    • /usr/share/doc/libdevil-old-devel/Libraries.txt
    • /usr/share/doc/libdevil-old-devel/README.unix
    • /usr/share/info/DevIL_manual.info.xz

    Changelog

    2015-08-04 - abfonly <abfonly@gmail.com> 1.7.8-14 - (afdc34e) Rename as devil-old, switch to gcc build, disable debug,fixed some linting, bump rel

    2015-08-04 - abfonly <abfonly@gmail.com> None - (e60ef43) Switch to gcc, fixed some linting disable debug - (abfonly: eef8aca) Switch to gcc. - (abfonly: 346e58f) Log: Try to coesxist with resil, if possible, a lot of apps won't build against resil - (Tomasz Pawe? Gajc: 4994f86) MassBuild#650: Increase release tag - (Bernhard Rosenkr?nzer: 4e9ed2e) Fix build - (Tomasz Pawe? Gajc: 003bc40) try this way for workaround bug with adding -std=gnu99 which is not allowed with C++ - (Bernhard Rosenkr?nzer: e0701ef) Rebuild in current environment (OpenEXR soname change) - (Tomasz Pawe? Gajc: e1d496e) spec file clean, use pkgconfig(libmng) - (Bernhard Rosenkraenzer: 6be4353) MassBuild#436: Increase release tag - (Bernhard Rosenkraenzer: 93282ff) MassBuild#289: Increase release tag - (Bernhard Rosenkraenzer: 47dcadd) MassBuild#289: Increase release tag - (Bernhard Rosenkraenzer: 9f59670) MassBuild#289: Increase release tag - (Bernhard Rosenkraenzer: 6ba3ae4) MassBuild#289: Increase release tag - (mdawkins (Matthew Dawkins): 89317fe) cleaned up spec - (alex: 4985d0c) merging with rosa2012.1 of project devil - (abondrov: bfd0855) Rebuild to deal with .la files issue, add patches for CVE-2009-3994 and libpng15 issues - (abondrov: bfd0855) SILENT: svn-revision: 786678 - (fwang: 893d61c) rebuild for new directfb - (fwang: 893d61c) SILENT: svn-revision: 622469 - (oden: 7e41df3) - rebuild - (oden: 7e41df3) SILENT: svn-revision: 610239 - (fwang: 6c59eac) rebuild for new libjpeg v7 - (fwang: 6c59eac) SILENT: svn-revision: 419751 - (eandry: a13fbc3) New version 1.7.8 - (eandry: a13fbc3) - new package devil-utils - (eandry: a13fbc3) SILENT: svn-revision: 402804 - (eandry: b320b0d) New version 1.7.7 - (eandry: b320b0d) - BR OpenEXR-devel - (eandry: b320b0d) - update files list - (eandry: b320b0d) SILENT: svn-revision: 351816 - (guillomovitch: bcb7248) fix static devel package dependencies - (guillomovitch: bcb7248) SILENT: svn-revision: 348589 - (guillomovitch: 9cfd95f) rebuild - (guillomovitch: 9cfd95f) SILENT: svn-revision: 348165 - (tpg: 41b6c9b) - allegro libraries are now compiled with -fPIC for x86_64, this should fix compiling of devil libraries - (tpg: 41b6c9b) - tune up configure options - (tpg: 41b6c9b) SILENT: svn-revision: 333804 - (eandry: 9bb9275) drop P1 and P3, files to patch are not present anymore - (eandry: 9bb9275) SILENT: svn-revision: 324465 - (fwang: 0b27987) fix obsoletes - (fwang: 0b27987) SILENT: svn-revision: 319214 - (adamw: d9bf1a2) - add headers.patch to fix a couple of header locations - (adamw: d9bf1a2) - and, ok, no_undefined is needed... - (adamw: d9bf1a2) - turns out we now need a configure flag to get ILU and ILUT built - (adamw: d9bf1a2) SILENT: svn-revision: 314091 - (adamw: 8b77d70) - use autoreconf not autogen.sh (it doesn't work right) - (adamw: 8b77d70) - add void.patch: fix inappropriate use of typedef void as a function argument - (adamw: 8b77d70) (breaks compilation of anything that builds against devil) - (adamw: 8b77d70) - rediff underlinking.patch - (adamw: 8b77d70) - new release 1.7.3 - (adamw: 8b77d70) - small cleanups - (adamw: 8b77d70) - no need to disable no_undefined - (adamw: 8b77d70) SILENT: svn-revision: 314087

    Advertisement
    Advertisement