libasync0.18-0.17.0-3-omv2015.0.i586.rpm


Advertisement

Description

libasync0.18 - Svxlink async libs

Property Value
Distribution OpenMandriva Lx 3.0
Repository OpenMandriva Contrib Release i586
Package name libasync0.18
Package version 0.17.0
Package release 3-omv2015.0
Package architecture i586
Package type rpm
Installed size 386.43 KB
Download size 116.32 KB
Official Mirror abf-downloads.openmandriva.org
The Async library is a programming framework that is used to write event driven
applications. It provides abstractions for file descriptor watches, timers,
network communications, serial port communications and config file reading.
Async is written in such a way that it can support other frameworks. Right now
there are two basic frameworks, a simple "select" based implementation and a Qt
implementation. The idea is that advanced libraries can be implemented in such
a way that they only depend on Async. That means that these libraries can be
used in both Qt and pure console applications and in any future frameworks
supported by Async (e.g. Gtk, wxWidgets etc).
Another big part of Async is the audio pipe framework. It is an audio handling
framework that is geared towards single channel (mono) audio applications. The
framework consists of a large number of audio handling classes such as
audio i/o, filtering, mixing, audio codecs etc.
This is a development version. The released version doesn't build on newer
Mandriva Distributions.

Alternatives

Package Version Architecture Repository
libasync0.18 - - -

Requires

Name Value
libQtCore.so.4 -
libQtGui.so.4 -
libQtNetwork.so.4 -
libasound.so.2 -
libasound.so.2(ALSA_0.9) -
libasound.so.2(ALSA_0.9.0rc4) -
libc.so.6 -
libc.so.6(GLIBC_2.0) -
libc.so.6(GLIBC_2.1) -
libc.so.6(GLIBC_2.1.2) -
libc.so.6(GLIBC_2.1.3) -
libc.so.6(GLIBC_2.15) -
libc.so.6(GLIBC_2.3) -
libc.so.6(GLIBC_2.3.4) -
libc.so.6(GLIBC_2.4) -
libc.so.6(GLIBC_2.7) -
libgcc_s.so.1 -
libgcc_s.so.1(GCC_3.0) -
libgsm.so.1 -
libpthread.so.0 -
libpthread.so.0(GLIBC_2.0) -
libpthread.so.0(GLIBC_2.1) -
libsigc-1.2.so.5 -
libspeex.so.1 -

Provides

Name Value
libasync0.18 == 0.17.0-3:2015.0
libasyncaudio.so.0.18 -
libasynccore.so.0.18 -
libasynccpp.so.0.18 -
libasyncqt.so.0.18 -

Download

Type URL
Binary Package libasync0.18-0.17.0-3-omv2015.0.i586.rpm
Source Package svxlink-11.11.1-3.src.rpm

Install Howto

  1. Enable OpenMandriva Contrib Release repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install libasync0.18 rpm package:
    # urpmi libasync0.18

Files

Path
/usr/lib/libasyncaudio-0.18.2.so
/usr/lib/libasyncaudio.so.0.18
/usr/lib/libasynccore-0.18.2.so
/usr/lib/libasynccore.so.0.18
/usr/lib/libasynccpp-0.18.2.so
/usr/lib/libasynccpp.so.0.18
/usr/lib/libasyncqt-0.18.2.so
/usr/lib/libasyncqt.so.0.18
/usr/share/doc/libasync0.18/ChangeLog

Changelog

2015-04-04 - abfonly <abfonly@gmail.com> 11.11.1-3
- (b3a927e) Merge pull request #1 from abfonly/svxlink:master
- (b3a927e) abfonly

See Also

Package Description
libatalk-devel-2.2.3-2-omv2015.0.i586.rpm Static library and header files for the atalk library
libatalk0-2.2.3-2-omv2015.0.i586.rpm Shared library for Appletalk and Appleshare/IP services for Linux
libatril-devel-1.14.0-1-omv2015.0.i586.rpm MATE Document viewer library
libatril-devel-1.8.1-1-omv2015.0.i586.rpm MATE Document viewer library
libatril-gir1.5.0-1.14.0-1-omv2015.0.i586.rpm GObject Introspection interface description for atril
libatril-gir1.5.0-1.8.1-1-omv2015.0.i586.rpm GObject Introspection interface description for atril
libatril3-1.14.0-1-omv2015.0.i586.rpm MATE Document viewer library
libatril3-1.8.1-1-omv2015.0.i586.rpm MATE Document viewer library
libaubio-devel-0.3.2-10-omv2015.0.i586.rpm Development files for aubio
libaubio2-0.3.2-10-omv2015.0.i586.rpm Main library for aubio
libaudiere-devel-1.9.4-12-omv2015.0.i586.rpm Development headers and libraries for audiere
libaudiere1.9.4-1.9.4-12-omv2015.0.i586.rpm High-level audio API
libauthd-devel-0.2.3-5-omv2013.0.i586.rpm Devel Package for authd
libautounit2-0.20.1-7-omv2013.0.i586.rpm C testing framework
libautounit2-devel-0.20.1-7-omv2013.0.i586.rpm Development files for autounit
Advertisement
Advertisement