perl-Term-UI-0.360.0-2-omv2014.0.noarch.rpm


Advertisement

Description

perl-Term-UI - Term::ReadLine UI made easy

Property Value
Distribution OpenMandriva Lx 2014.2
Repository OpenMandriva Main x86_64
Package name perl-Term-UI
Package version 0.360.0
Package release 2-omv2014.0
Package architecture noarch
Package type rpm
Installed size 31.42 KB
Download size 18.88 KB
Official Mirror abf-downloads.openmandriva.org
"Term::UI" is a transparent way of eliminating the overhead of having to format
a question and then validate the reply, informing the user if the answer was
not proper and re-issuing the question.
Simply give it the question you want to ask, optionally with choices the user
can pick from and a default and "Term::UI" will DWYM.
For asking a yes or no question, there's even a shortcut.

Alternatives

Package Version Architecture Repository
perl-Term-UI-0.420.0-1-omv2014.0.noarch.rpm 0.420.0 noarch OpenMandriva Main Updates
perl-Term-UI-0.420.0-1-omv2014.0.noarch.rpm 0.420.0 noarch OpenMandriva Main Updates
perl-Term-UI-0.360.0-2-omv2014.0.noarch.rpm 0.360.0 noarch OpenMandriva Main
perl-Term-UI - - -

Requires

Name Value
perl(Carp) -
perl(Exporter) -
perl(Locale::Maketext::Simple) -
perl(Log::Message) -
perl(Log::Message::Simple) -
perl(Params::Check) -
perl(Term::ReadLine) -
perl(abi) >= 5.16.3

Provides

Name Value
perl(Term::UI) == 0.360.0
perl(Term::UI::History) -
perl-Term-UI == 0.360.0-2:2014.0

Download

Type URL
Binary Package perl-Term-UI-0.360.0-2-omv2014.0.noarch.rpm
Source Package perl-Term-UI-0.360.0-2.src.rpm

Install Howto

  1. Enable OpenMandriva Main repository on Install and Remove Software"
  2. Update packages list:
    # urpmi.update -a
  3. Install perl-Term-UI rpm package:
    # urpmi perl-Term-UI

Files

Path
/usr/lib/perl5/vendor_perl/5.16.3/Term/UI.pm
/usr/lib/perl5/vendor_perl/5.16.3/Term/UI/History.pm
/usr/share/doc/perl-Term-UI/README
/usr/share/man/man3/Term::UI.3pm.xz
/usr/share/man/man3/Term::UI::History.3pm.xz

Changelog

2014-02-08 - Tomasz Pawe? Gajc <tpgxyz@gmail.com> 0.360.0-2
+ Revision: aac90b8
- MassBuild#328: Increase release tag

See Also

Package Description
perl-Test-Base-0.600.0-7-omv2014.0.noarch.rpm A Data Driven Testing Framework
perl-Test-CPAN-Meta-0.180.0-8-omv2014.0.noarch.rpm Validation of META.yml specification elements
perl-Test-ClassAPI-1.60.0-7-omv2014.0.noarch.rpm Test::ClassAPI - Provides basic first-pass API testing for large class trees
perl-Test-Deep-0.108.0-7-omv2014.0.noarch.rpm Extremely flexible deep comparison
perl-Test-Differences-0.610.0-5-omv2014.0.noarch.rpm Test strings and data structures and show differences if not ok
perl-Test-Exception-0.310.0-8-omv2014.0.noarch.rpm Test exception based code
perl-Test-Fatal-0.6.0-6-omv2014.0.noarch.rpm Incredibly simple helpers for testing code with exceptions
perl-Test-Harness-3.260.0-3-omv2014.0.noarch.rpm Run Perl standard test scripts with statistics
perl-Test-Inter-1.30.0-6-omv2014.0.noarch.rpm Framework for more readable interactive test scripts
perl-Test-LongString-0.150.0-6-omv2014.0.noarch.rpm Perl module to test strings for equality
perl-Test-Manifest-1.230.0-7-omv2014.0.noarch.rpm Interact with a t/test_manifest file
perl-Test-Memory-Cycle-1.40.0-6-omv2014.0.noarch.rpm Check for memory leaks and circular memory references
perl-Test-MinimumVersion-0.101.80-7-omv2014.0.noarch.rpm Does your code require newer perl than you think?
perl-Test-Most-0.240.0-7-omv2014.0.noarch.rpm Most commonly needed test functions and features
perl-Test-NoWarnings-1.20.0-7-omv2014.0.noarch.rpm Make sure you didn't emit any warnings while testing
Advertisement
Advertisement