jansi-1.11-3.1-omv2014.0.noarch.rpm


Advertisement

Description

jansi - Jansi is a java library for generating and interpreting ANSI escape sequences

Property Value
Distribution OpenMandriva Lx 2014.2
Repository OpenMandriva Main Release x86_64
Package name jansi
Package version 1.11
Package release 3.1-omv2014.0
Package architecture noarch
Package type rpm
Installed size 66.72 KB
Download size 42.35 KB
Official Mirror abf-downloads.openmandriva.org
Jansi is a small java library that allows you to use ANSI escape sequences
in your Java console applications. It implements ANSI support on platforms
which don't support it like Windows and provides graceful degradation for
when output is being sent to output devices which cannot support ANSI
sequences.

Alternatives

Package Version Architecture Repository
jansi-1.11-3.1-omv2014.0.noarch.rpm 1.11 noarch OpenMandriva Main Release
jansi - - -

Requires

Name Value
java >= 1.5
jpackage-utils -
mvn(org.fusesource.hawtjni:hawtjni-runtime) -
mvn(org.fusesource.jansi:jansi-native) -

Provides

Name Value
jansi == 1.11-3.1:2014.0
mvn(org.fusesource.jansi:jansi) == 1.11
mvn(org.fusesource.jansi:jansi-project) == 1.11
mvn(org.fusesource.jansi:jansi-project:pom:) == 1.11
osgi(org.fusesource.jansi) == 1.11.0

Download

Type URL
Binary Package jansi-1.11-3.1-omv2014.0.noarch.rpm
Source Package jansi-1.11-3.1.src.rpm

Install Howto

  1. Enable OpenMandriva Main Release repository on Install and Remove Software
  2. Update packages list:
    # urpmi.update -a
  3. Install jansi rpm package:
    # urpmi jansi

Files

Path
/usr/share/doc/jansi/changelog.md
/usr/share/doc/jansi/license.txt
/usr/share/doc/jansi/readme.md
/usr/share/java/jansi/jansi.jar
/usr/share/maven-effective-poms/JPP.jansi-jansi.pom
/usr/share/maven-fragments/jansi.xml
/usr/share/maven-poms/JPP.jansi-jansi-project.pom
/usr/share/maven-poms/JPP.jansi-jansi.pom

Changelog

2014-01-11 - pcpa <paulo.cesar.pereira.de.andrade@gmail.com> 1.11-3.1
+ Revision: ea7413e
- Satisfy unavoidadble rpmlint error that should be a warning

See Also

Package Description
jansi-javadoc-1.11-3.1-omv2014.0.noarch.rpm Javadocs for jansi
jansi-native-1.5-1.1-omv2014.0.x86_64.rpm Jansi Native implements the JNI Libraries used by the Jansi project
jansi-native-javadoc-1.5-1.1-omv2014.0.x86_64.rpm Javadocs for jansi-native
jarjar-1.4-4.0-omv2014.0.noarch.rpm Jar Jar Links
jarjar-javadoc-1.4-4.0-omv2014.0.noarch.rpm Javadoc for jarjar
jarjar-maven-plugin-1.4-4.0-omv2014.0.noarch.rpm Maven plugin for jarjar
jasper-1.900.1-22-omv2014.0.x86_64.rpm JPEG-2000 utilities
jasperreports-4.0.2-6.0-omv2014.0.noarch.rpm Report-generating tool
jasperreports-javadoc-4.0.2-6.0-omv2014.0.noarch.rpm Javadoc for jasperreports
jasperreports-manual-4.0.2-6.0-omv2014.0.noarch.rpm Manual for jasperreports
java-1.5.0-gcj-1.5.0.0-28-omv2014.0.noarch.rpm JPackage runtime scripts for GCJ
java-1.5.0-gcj-devel-1.5.0.0-28-omv2014.0.noarch.rpm JPackage development scripts for GCJ
java-1.5.0-gcj-javadoc-1.5.0.0-28-omv2014.0.noarch.rpm API documentation for libgcj
java-1.5.0-gcj-src-1.5.0.0-28-omv2014.0.noarch.rpm Source files for libgcj
java-1.6.0-openjdk-devel-1.6.0.0-33.b27-omv2014.0.x86_64.rpm OpenJDK Development Environment
Advertisement
Advertisement